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การใชโ้ปรแกรม Captivate 5.5 

                       ทองจุล ขันขาว 
                      สถาบนั กศน.ภาคกลาง   http://www.crnfe.ac.th 

 

 โปรแกรม Captivate เป็นโปรแกรมส าหรับสร้างมลัตมีิเดียบนเว็บ การจบัภาพหน้าจอ การท า

ภาพเคล่ือนไหว และอ่ืน ๆ โปรแกรม Captivate สามารถสร้างบทเรียนแบบมีปฏิสมัพนัธ์ สร้างข้อสอบ ได้

อยา่งดี โดยผู้ใช้ไมจ่ าเป็นต้องเขียนค าสัง่ เพราะโปรแกรมมีค าสัง่ตา่ง ๆ ไว้ให้เลือกผา่นทางหน้าจอของ

โปรแกรม จงึเป็นโปรแกรมท่ีใช้งานง่าย เรียนรู้ได้เร็ว เหมาะส าหรับครู และผู้ ท่ีมีหน้าท่ีฝึกอบรมบคุลากร 

นอกจากนีย้งัสามารถใช้ Widget หรือเขียน Action Script 3 เพิ่มขีดความสามารถของโปรแกรมได้ และ

สามารถ สง่ขึน้เว็บ Youtube ได้ทนัที หรือจะท าเป็นไฟล์ PDF ก็ได้ 

โปรแกรม Captivate มีจดุประสงค์หลกัส าหรับใช้เลน่บนอินเทอร์เน็ต ผา่นทาง Browser หรือใช้กบั 

LMS โดยสง่ออกไปใช้งานเป็น Flash (swf) ตามมาตรฐาน Scorm อยา่งไรก็ตาม โปรแกรมสามารถสง่ออก

เป็นไฟล์ exe และน าไปเลน่บนเคร่ืองคอมพิวเตอร์ท่ีไมไ่ด้ตอ่กบัอินเทอร์เน็ตได้ 

คณุสมบตัใิหมข่อง รุ่น 5.5 คือ สามารถสง่เข้าเผยแพร่บนเว็บ Youtube ได้ทนัที สามารถส่งออก

เป็นไฟล์ MP4 เพ่ือใช้กบั tablets smartphone และ  iOS devices หรือ สง่ออกเป็น PDF ก็ได้ สามารถเพิ่ม

เงาให้กบัวตัถบุนหน้าจอ ท าให้มีมิต ินอกจากนีย้งัสามารถใช้แมแ่บบส าเร็จรูปส าหรับสร้างข้อสอบได้ง่าย

ขึน้และสวยงามขึน้อีกด้วย 
 

หลักการพืน้ฐาน 

 โปรแกรม Captivate ท างานในลกัษณะเดียวกบัโปรแกรม MS PowerPoint คือในแตล่ะไฟล์ หรือ 

Project จะประกอบไปด้วย Slide หลาย Slide น ามาเรียงกนั ในแตล่ะ Slide สามารถบรรจสุิ่งตา่ง ๆ ซึง่

ตอ่ไปนี ้จะเรียกวา่เป็น วตัถ ุเชน่ ภาพ ข้อความ เสียง คลิปวิดีโอ และ ปุ่ ม เป็นต้น การเข้า-ออกของ Slide 

และวตัถใุน Slide สามารถก าหนด Effects ตา่ง ๆ ได้ 

 เม่ือสัง่ให้โปรแกรมท างาน โปรแกรมจะเร่ิมน าแผ่น Slide ท่ี 1 มาแสดง จากนัน้จะน าเอาแผน่ Slide 

ท่ี 2 และ 3 มาแสดงเร่ือย ๆ จนหมดทกุ Slide การควบคมุ Slide ให้ไปยงัแผน่ Slide ท่ีก าหนด ท าได้โดยการ

สร้างปุ่ ม และใช้ค าสัง่ของโปรแกรม เพ่ือให้ไปยงั Slide ท่ีต้องการ  

http://www.crnfe.ac.th/
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 Slide แตล่ะแผน่ จะมี Timeline เป็นของตนเอง Timeline จะเป็นตวัก าหนดเวลาการแสดงของวตัถุ

แตล่ะตวัในแผน่ Slide นัน้ ๆ ตลอดจน การก าหนดให้วตัถใุดเกิดก่อน หรือเกิดหลงัอย่างไร หรือการก าหนด

ต าแหนง่ของวตัถใุห้อยูข้่างหน้า หรืออยู่หลงัวตัถใุด ก็ได้ 

 วตัถแุตล่ะวตัถ ุเชน่ ภาพ ข้อความ เสียง และวิดีโอ สามารถปรับแก้ลกัษณะได้ ผา่นทางแถบ 

Properties โดย วตัถแุตล่ะอยา่ง จะมีแถบ Properties ของตนเอง เม่ือคลิกเลือกวตัถใุด โปรแกรม 

Captivate จะแสดง Properties ของวตัถนุัน้ ท าให้สามารถก าหนดลกัษณะของวตัถนุัน้ ๆ ได้ 

หน้าจอและเมน ู

 

 

 

 หน้าจอหลักของ Captivate มีดังนี ้

 

1. เมนู  
 

 

 File  ส าหรับการสร้าง/เปิดไฟล์ใหม ่การบนัทกึ การสง่ออกเพ่ือใช้งาน และการเลน่ไฟล์ 

(Preview) เป็นต้น 

 Edit ส าหรับการคดัลอก วาง ภาพ ข้อความ หรือ แผน่ Slide ตลอดจนการก าหนดคา่ของ

โปรแกรม (Preferences) เป็นต้น 

 View มมุมองของหน้าจอ ปรับหน้าจอขนาดตา่ง ๆ การซอ่น Slide เป็นต้น 

Document 

Window 

Panel Groups 

Toolbar 

เมนู 

Properties 

    Slide 

Timeline 

Filmstrip 
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Selection Tool 

Insert Text Caption 

Insert Button 

 Insert ส าหรับการน าเข้าวตัถตุา่ง ๆ เชน่ เพิ่ม Slide เพิ่มข้อสอบ ภาพนิ่ง ภาพเคล่ือนไหว และปุ่ ม 

เป็นต้น 

 Modify ส าหรับการเปล่ียนขนาดของหน้าจอแสดงผล (Document Window) ก าหนดต าแหนง่ การ

จดัเรียงวตัถตุา่ง ๆ บนหน้าจอ (Alignment) เป็นต้น 

 Project ส าหรับการเปล่ียนรูปร่างหน้าตา (skin editor) การสร้างตวัแปร เป็นต้น 

 Quiz  ส าหรับสร้างข้อสอบแบบตา่ง ๆ และการก าหนดคา่ของข้อสอบ เป็นต้น 

 Audio ส าหรับการจดัการเก่ียวกบัเสียง เชน่ การน าเข้า และการตดัตอ่เสียง เป็นต้น 

 Video ส าหรับการจดัการคลิปวิดีโอ ไฟล์ วิดีโอท่ีใช้ได้ ได้แก่ flv f4v avi mov mp4และ 3gp ในกรณี

ท่ีไมใ่ช ่flv หรือ f4v โปรแกรม Captivate จะแปลงไฟล์ก่อนการ

น าเข้า 

 Window ส าหรับการเปิดหรือปิดการใช้งาน Panal ตา่ง ๆ 

ในหน้าจอ เชน่ Timeline Filmstrip Effects และ Properties เป็นต้น 

Panal ใดท่ีก าลงัเปิดอยู ่จะเห็นมีเคร่ืองหมายถกูปรากฏอยูข้่างหน้า 

ถ้าต้องการปิด ให้คลิกเพ่ือเอาเคร่ืองหมายถกูออกไป  
2. Toolbars 

เป็นกลุม่เคร่ืองมือท่ีน ามาวางไว้ เพ่ือให้สามารถใช้ได้อย่าง

สะดวก เคร่ืองมือในแถบ Toolbars นีท้กุตวั สามารถเข้าถึงได้

จากเมน ูเคร่ืองมือท่ีควรรู้จกั มีดงันี ้

2.1. Selection Tool เป็นเคร่ืองมือส าหรับใช้เลือกวตัถตุา่ง ๆ ท่ี

อยูบ่นหน้าจอ เม่ือใช้เคร่ืองมือนีค้ลิกท่ีวตัถใุดบนหน้าจอ จะเห็น Properties ของวตัถนุัน้ ๆ แสดง

ในแถบ Properties และสามารถท่ีจะปรับปรุง แก้ไข หรือก าหนดใหมไ่ด้ 

2.2. Insert Text Caption เป็นเคร่ืองมือท่ีใช้บอ่ย ส าหรับการพิมพ์ตวัอกัษร โดยจะมีพืน้เป็นแถบคล้าย

ป้ายรองรับ เราสามารถเปล่ียนลกัษณะของพืน้ หรือ จะก าหนดให้ไมเ่ห็นพืน้เลย ก็ได้ โดยไปท่ี

แถบ Properties และก าหนดเป็น Transparent 

2.3. Insert Button เป็นเคร่ืองมือสร้างปุ่ มบนหน้าจอ เม่ือคลิกเคร่ืองมือนี ้จะเกิดปุ่ มท่ีกลางหน้าจอโดย

อตัโนมตัิ เราสามารถลากปุ่ มท่ีเกิดขึน้ไปยงัต าแหนง่ใด ๆ ท่ีต้องการบนหน้าจอ และสามารถ



4 

 

 

ก าหนด Action หรือค าสัง่ของปุ่ มวา่ เม่ือกดปุ่ มนีแ้ล้วให้ท าอะไร เชน่ ให้ไปยงั Slide ตอ่ไป หรือ ให้

ไปยงั Slide ท่ีก าหนด เป็นต้น 

3. Panel Groups  เป็นกลุม่แถบท่ีอยู่ด้านซ้ายมือ ประกอบด้วย ตา่ง ๆ ท่ี

สามารถก าหนดคา่ให้แก่วตัถตุา่ง ๆ ท่ีอยู่บนหน้าจอได้ 

3.1. Properties เป็นแถบส าคญัท่ีก าหนดคณุลกัษณะของวตัถท่ีุถกู

เลือกบนหน้าจอ เชน่ ภาพ ข้อความ ปุ่ ม เป็นต้น  

3.2. Library เป็นแถบท่ีรวมวตัถตุา่ง ๆ ท่ีอยูบ่นหน้าจอมาไว้ท่ีน่ี เม่ือ

เราน า ภาพ เสียง หรือ วิดีโอ มาวางบนหน้าจอ โปรแกรม Captivate จะน ามาไว้ใน Library ให้โดย

อตัโนมตัิ ถ้าเราต้องการน ามาใช้อีก ก็สามารถน าวตัถท่ีุอยูใ่น Library มาวางไว้บนหน้าจอ และ

ก าหนด Property เสียใหมไ่ด้ ท าให้ประหยดั เพราะไมต้่องน าเข้าวตัถใุหม ่ซึง่ท าให้เปลือง

หนว่ยความจ าของเคร่ืองคอมพิวเตอร์ 

3.3. Filmstrip เป็นสว่นท่ีแสดง Slide ทัง้หมดในโปรแกรม โดยเรียงล าดบัก่อนหลงัตามล าดบัการ

น าเสนอ Slide แตล่ะแผ่นสามารถใช้

เมาส์ลากเพ่ือสลบัต าแหนง่กนัได้จากใน 

Filmstrip ได้ 

            ใน Slide แตล่ะแผน่ ควรมีการ

ตัง้ช่ือ Slide ในแถบ Properties ด้วย ซึง่

มีประโยชน์ในการก าหนดเส้นทางการ

เดนิของโปรแกรม เชน่ เม่ือคลิกปุ่ มแล้ว 

จะให้โปรแกรมไปท่ี Slide ใด เป็นต้น ช่ือ

ของ slide แตล่ะแผน่จะปรากฏท่ี

ด้านลา่ง ของ Slide นัน้ ๆ และนอกจากนี ้ถ้า Slide นัน้มี วิดีโอ หรือมีการใช้เสียง ก็จะมีสญัลกัษณ์

ปรากฏให้เห็น 

 

4. Document Window  

เป็นหน้าจอแสดงผลของโปรแกรม โดยจะแสดง Slide ทีละแผน่ วตัถตุา่ง ๆ ท่ีน ามาวาง ใน Slide 

แตล่ะแผน่ จะปรากฏท่ีน่ี เม่ือเปิดโปรแกรม Captivate ใหม ่โปรแกรมจะให้ก าหนดขนาดของหน้าจอนี ้เรา

สามารถปรับมมุมองของหน้าจอนี ้ให้เล็กหรือใหญ่เพ่ือสะดวกในการท างานได้ โดย กดปุ่ ม Ctrl ค้างไว้และ

 

ช่ือ Slide 

 

สญัลกัษณ์ วิดีโอ 

 

สญัลกัษณ์ เสยีง 
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และกดปุ่ มเคร่ืองหมายเทา่กบั จะขยายให้ใหญ่ขึน้ แตถ้่ากดปุ่ ม Ctrl ค้างไว้และกดปุ่ มเคร่ืองหมายลบ จะ

ยอ่หน้าจอให้เล็กลง การกดปุ่ มข้างต้น ไมมี่ผลตอ่ขนาดของหน้าจอ แตเ่ป็นการย่อหรือขยายมมุมองนี ้

เพ่ือให้สามารถท างานได้สะดวกขึน้ เทา่นัน้ 

ถ้ามีการเปิดโปรแกรม Captivate หลายโปรแกรมพร้อมกนั จะเกิดแถบและมีช่ือของไฟล์ปรากฏ

ให้เห็น ท าให้สามารถสลบัไป-มาระหวา่งโปรแกรมได้ และยงัสามารถคดัลอกวตัถตุา่ง ๆ ข้ามโปรแกรมได้ 

โดยใช้ Copy และ Paste ระหวา่งกนัได้ 

 
5. Timeline  

 

 

 

 

 

 

 

Timeline เป็นแถบควบคมุวตัถ ุท่ีอยูใ่นแผน่ Slide แผน่ท่ีก าลงัแสดงอยูใ่นหน้าจอ Document 

Window ทัง้นี ้Slide แตล่ะแผน่ จะมี Timeline เป็นของตนเอง Timeline ประกอบด้วยชัน้ หรือ layers ตา่ง ๆ 

หลายชัน้ แตล่ะชัน้คือวตัถแุตล่ะอย่างในแผน่ Slide นัน้ ๆ ซึง่จะมีช่ือปรากฏอยูใ่ห้สงัเกตได้ เชน่ ในภาพ 

Btton_3 เป็นชัน้ของปุ่ มท่ีช่ือ Button_3 เป็นต้น  

ชัน้แตล่ะชัน้ สามารถปรับความยาว ให้ปรากฏก่อนหลงัได้โดยใช้เมาส์ลากให้สัน้ลง หรือยาวขึน้

ได้ และนอกจากนี ้ยงัลากสลบัต าแหนง่ บน-ลา่ง ได้ วตัถท่ีุอยูช่ัน้บนกว่า จะอยูห่น้าวตัถท่ีุอยูช่ัน้ลา่ง ใน 
Document Window 

ท่ีด้านล่างมีปุ่ มควบคมุ ให้เล่น Slide แผน่นี ้สามารถเลน่ หรือหยดุได้ โดยใช้ปุ่ ม หรืออาจจะ คลิก

และลากหวัอา่นสีแดง เพื่อดคูวามเปล่ียนแปลงได้ 

นอกจากนี ้ถ้ามีการเปิด Panel เชน่ Master slide หรือ Effects จะเห็นมีแถบปรากฏเพิ่มขึน้ท่ีน่ี ซึง่

จะสามารถใช้งาน Panel นัน้ ๆ ได้จากท่ีน่ี เชน่กนั 
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การสร้าง Slide ใหม ่และการน าเข้าวตัถ ุ

 

1. การเพิ่ม Slide  

 

1.1. การเพิ่ม Slide เปลา่ ให้ไปท่ีเมน ูInsert > Blank Slide  โปรแกรมจะสร้าง Slide เปลา่ให้ โดยไมมี่

วตัถใุด ๆ และจะใช้พืน้หลงัของโปรแกรม โดยปกต ิ(คา่ Default )จะเป็นสีขาว  

1.2. การเพิ่ม Slide เปลา่ และมีแมแ่บบพืน้หลงั ให้ไปท่ี Insert > New Slide โปรแกรม จะสร้าง Slide 

ใหม ่และน าพืน้หลงัของแมแ่บบท่ีก าหนดมาใช้ด้วย ท าให้กลมกลืนกับ Slide ก่อนหน้านี ้

 

2. การเพิ่มข้อความ  
 

2.1. ให้ไปท่ี Insert > Standard Objects > Text Caption หรือคลิกท่ีปุ่ ม Insert Text Caption บนแถบ

เคร่ืองมือ จะปรากฏแถบส าหรับพิมพ์ข้อความ ให้พิมพ์ข้อความท่ีต้องการแล้วปรับคา่ ตา่ง ๆ ใน

แถบ Properties 

2.2. การก าหนดคา่ใน Properties ของข้อความ มีดงันี ้

 Item Name ช่ือของข้อความ ให้ใช้ภาษาองักฤษเสมอ 

 GENERAL สามารถเปล่ียนลกัษณะของแถบ เชน่ สีพืน้ 

รูปร่าง เป็นต้น ถ้าไมต้่องการให้มีพืน้ ให้คลิกสามเหล่ียม และ

เลือก Transparent 

 CHARACTER ส าหรับก าหนดคา่ตา่ง ๆ ของ Fonts เชน่ 

Fonts ขนาด และสี  

 FORMAT ส าหรับก าหนดให้จดัชิดซ้าย-ขวา เป็นต้น 

 TIMING ส าหรับก าหนดระยะเวลาท่ีจะให้แสดง และระยะเวลาท่ีจะให้ปรากฏหลงัจากท่ี Slide ปรากฏ 

เชน่  จากภาพด้านล่าง เป็นการก าหนดให้ Slide มีความยาว 3 วินาที และจะเร่ิมแสดงให้เห็นเม่ือเปิด 

Slideเข้ามาแล้ว 2 วินาที ดงันัน้ Slide นี ้จะมีความยาวทัง้หมด 5 วินาที เม่ือดท่ีู Timeline เห็นดงัภาพ 
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 TRANSITION ส าหรับก าหนดการเข้ามาของข้อความ โดยปกตจิะให้คอ่ย ๆ จางเข้าและจางออกไป 

(Fade In and Out) เราสามารถเปล่ียนแปลงได้ เชน่ ให้เข้ามาทนัที แตเ่วลาออกให้คอ่ย ๆ จางออก 

(Fade Out Only) หรือ ไมใ่ห้มี Transition เลย ก็ได้ 

 Audio ส าหรับเพิ่มเสียงเม่ือข้อความนีป้รากฏ  

 POSITION & SIZE ส าหรับก าหนดต าแหนง่และขนาด ต าแหนง่ X คือระยะห่างจากขอบหน้าจอซ้าย 

และ ต าแหนง่ Y คือระยะหา่งจากขอบบนของ Document Window 

 

3. การเพิ่มภาพ 

 

Captivate สามารถน าภาพเข้าโปรแกรม และสามารถเปิดไฟล์ Photoshop และสามารถท างาน

กบัโปรแกรม Photoshop ได้  

3.1. การน าภาพเข้าโปรแกรม ไปท่ี Insert > Image และเลือกไฟล์ท่ีต้องการ 

3.2. Properties ของภาพ มีดงันี ้

 Item Name ช่ือปุ่ ม ใช้ภาษาองักฤษ 

 IMAGE ช่ือของภาพ และการท าให้สีบางสีในภาพมอง

ไมเ่ห็น โดยคลิกท่ี Fill ( ) และใช้ปากกาดดูสี (Color picker) 

เลือกสีในภาพ หรือ ก าหนดเองจากแผน่สี ก็ได้ 

 IMAGE EDIT  สามารถปรับแก้สีของภาพ เชน่ ความ

สวา่ง ความเข้ม เปล่ียนภาพเป็นสีเทา การหมนุภาพ การตดั

บางสว่นของภาพออก เป็นต้น นอกจากนีย้งัสามารถปรับความ

โปร่งใสของภาพ โดยการปรับคา่ Alpha จากเมน ูได้อีกด้วย  

 TIMING  ก าหนดเวลาท่ีภาพแสดงใน Slide และเวลาเร่ิม

ท่ีจะให้ภาพปรากฏ 

 TRANSITION ส าหรับตัง้ลกัษณะการ Fade เข้า-ออกของ

ภาพ 

 AUDIO  ส าหรับใสเ่สียงในภาพ เม่ือภาพปรากฏจะมี

เสียงตามท่ีก าหนด  

 POSITION & SIZE  ส าหรับการก าหนดต าแหนง่ และขนาดของภาพ 
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4. การสร้าง Rollover Image 

 

Rollover Image ได้แกภ่าพท่ีปรากฏขึน้เม่ือเมาส์ลากผา่นสิ่งใดสิ่งหนึง่ หรือบริเวณใดบริเวณหนึง่

บนแผน่ Slide เชน่ ข้อความบนแผน่ Slide หรือภาพใด ๆ บนแผน่ Slide มีวิธีการ ดงันี ้

4.1. เปิด Slide ใหม ่

4.2. สร้างข้อความหรือภาพเป้าหมายท่ีจะให้เมาส์ลากผ่าน 

4.3. ไปท่ี Insert > Standard Objects >Rollover Image.. และเลือกภาพท่ีจะน ามาท าเป็น Rollover 

Image 

4.4. จะเกิดภาพพร้อมทัง้กรอบส่ีเหล่ียมสีน า้เงิน 

 
 

4.5. ลากกรอบสีน า้เงิน ไปวางทบับริเวณท่ีต้องการให้เมาส์ลากผา่น และแสดงภาพท่ีน าเข้า พร้อมทัง้

ลากขอบเปล่ียนขนาด และย้ายต าแหนง่ของภาพตามต้องการ  

 

4.6. ถ้าไมต้่องการให้แสดงกรอบสีน า้เงินแสดงให้เห็น ให้คลิกท่ีกรอบสีน า้เงิน และก าหนดคา่ Stroke 

ในแถบ PROPERITES > FILL & STROKE โดยก าหนดให้เป็น 0 จะไมเ่ห็นกรอบสีน า้เงิน 

4.7. ทดสอบ โดยไปท่ี File > Preview > Project และน าเมาส์ไปวางบริเวณท่ีน ากรอบสีน า้เงินไปวางทบั

ไว้ จะเห็นภาพท่ีก าหนดเป็น Rollover Image ปรากฏขึน้ 
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5. การใช้ Effects 

Captivate สามารถมี Effects ท่ีนา่สนใจจ านวนมาก ตัง้แตก่ารใช้ Transition ของ Slide เพ่ือ

ก าหนดลกัษณะการเข้า-ออกของ Slide การก าหนด Effects ให้กบั วตัถตุา่ง ๆ บน Slide เชน่ ภาพ ข้อความ 

ปุ่ ม การใช้ภาพเคล่ือนไหวจากไฟล์ swf หรือ Gif animation ตลอดจนการใช้ Text Animation ตา่ง ๆ 

อยา่งไรก็ตาม การใช้ Effects ต้องค านงึถึงความเหมาะสม เพ่ือให้สามารถดงึดดูความสนใจของผู้ใช้ การใช้ 

Effects มากเกินไปอาจจะท าให้ผู้ใช้ไมส่นใจเนือ้หาท่ีน าเสนอได้ 
5.1. Slide Transition  

 คลิกท่ีแผน่ Slide 

 ท่ีแถบ PROPERTIES > GENERAL เลือก Transition ท่ีต้องการ 

 

5.2. การใช้ Effects กบัวตัถตุา่ง ๆ บนหน้าจอ 

วตัถตุา่ง ๆ เช่น ภาพ ปุ่ ม ข้อความ สามารถใช้ Effects ท าให้ดงึดดูความสนใจได้ ดนู่าสนใจมาก

ยิ่งขึน้ 

 คลิกท่ีวตัถท่ีุต้องการใส่ Effects 

 ถ้าท่ีแถบ Timeline ไมมี่แถบ Effects ให้ไปท่ี Window > Effects 

 ท่ีแถบ Effects บน Timeline คลิกปุ่ ม Add Effect ( ) เพ่ือก าหนด Fx ให้กบัวตัถนุัน้ 
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 เลือก Effects จากรายการท่ีเห็น เชน่ พืน้ฐาน การเข้า-ออกของวตัถ ุเป็นต้น Effect แตล่ะตวัจะ

มีรายการยอ่ย ๆ อีกหลายรายการให้เลือก  

 

 ถ้าต้องการลบ Effects ให้คลิกเลือก Effect นัน้ ๆ แล้วคลิกท่ีถงัขยะ 

5.3. การใช้ภาพเคล่ือนไหวจากไฟล์ Animation เชน่ swf หรือ Gif animation  

สามารถน าเข้าผา่นทางเมน ูInsert > Animation… ซึง่โปรแกรม Captivate 5 ได้เตรียมไฟล์ swf 

ไว้จ านวนมากให้เลือกใช้ โดยเก็บไว้ท่ี ห้องโปรแกรม Captivate 5/Gallery/SWF Animation 

5.4. การใช้ Text Animation 

 ไปท่ี Insert Text Animation หรือ คลิกท่ีเคร่ืองมือ Insert Text Animation ( ) 

 

 พิมพ์ข้อความ ปรับขนาดและตวัอกัษร และถ้าต้องการให้เลน่วน ในคลิกหน้า Loop แล้วคลิก 
OK 

 ปรับรูปแบบของ Animation จากในแถบ PROPERTIES > GENERAL > Effect ซึง่จะมี Effects ให้

เลือกจ านวนมาก ถ้าไมพ่บ Effect แสดงวา่ ข้อความท่ีพิมพ์เข้ามาไมถ่กูเลือก ให้คลิกเลือก

ข้อความนัน้ก่อน  
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6. การเพิ่มปุ่ม 

 

ปุ่ มท าหน้าท่ีบงัคบัการควบคมุหน้าจอ (Navigation) ของโปรแกรม โดยการใสค่ าสัง่ท่ีปุ่ มให้ไปยงั 

Slide ใด ๆ หรือให้กระท าการใด ๆ ตามค าสัง่   

6.1. ไปท่ี Insert > Standard Objects > Button หรือคลิกท่ีปุ่ ม Insert Button บนแถบเคร่ืองมือ จะเกิด

ปุ่ มท่ีบริเวณกลาง Document Window ซึง่สามารถลากไปยงัต าแหนง่ท่ีต้องการ และปรับคา่ใน 

Properties ตามต้องการ 

6.2. แถบ Properties ของ ปุ่ ม 

 Item Name ช่ือปุ่ ม ให้ก าหนดเป็นภาษาองักฤษ 

 GENERAL  สามารถเลือกประเภทของปุ่ มและก าหนด

ข้อความบนปุ่ มได้  

-ปุ่ มมี 3 ประเภท ได้แก่  

      1)Text Button เป็นปุ่ มท่ีมีข้อความทบัอยู่บนปุ่ ม สามารถ

เปล่ียนข้อความได้จากช่อง Caption และควรใช้ภาษาไทย  

     2)Transparent เป็นปุ่ มโปร่งใส มองไมเ่ห็น แตส่ามารถคลิก

ได้ มีคณุสมบตัขิองปุ่ ม ทกุประการ ใช้ส าหรับน าไปครอบ

ข้อความหรือภาพท่ีต้องการให้คลิก  ปุ่ ม Transparent จะมี

คณุสมบตัด้ิาน FILL&STROKE เพิ่ม ให้ก าหนดคา่ alpha ของ 

Fill เทา่กบั 0 และถ้าไมต้่องการเส้นขอบ ให้ก าหนดคา่ Stroke เป็น 0 เชน่เดียวกนั ดงัภาพ 
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                         การก าหนดคา่ alpha ของ Fill และ เส้นขอบ (Stroke) 

3)Image Button เป็นปุ่ มท่ีใช้ภาพ Captivate 5 มีปุ่ มจ านวนมากเตรียมไว้ให้ในห้องของโปรแกรม 

/Gallery/Buttons/ แตส่ว่นใหญ่จะมีข้อความเป็นภาษาองักฤษ ถ้าต้องการสร้างเองสามารถท าได้ โดย

ใช้โปรแกรมกราฟิก เชน่ Gimp หรือ Photoshop โดยให้สร้างปุ่ ม 3 ปุ่ ม คือปุ่ ม สถานะปกต ิ(up) ขณะ

เมาส์ลากผา่น (over) และขณะกดเมาส์ (down) ประการส าคญัคือ ต้องใช้ช่ือปุ่ มช่ือเดียวกนั แตต่อ่ท้าย

ด้วย _up, _over และ _down เชน่ ถ้าปุ่ มนีค้ลิกแล้ว ให้ท าตอ่ไป อาจใช้ช่ือว่า next_up, next_over และ 

next_down เป็นต้น  

                              
                         next_up           next_over              next_down 
น าปุ่ มทัง้ 3 ไปไว้ในห้องเดียวกนั เม่ือจะน าเข้า ให้ก าหนดประเภทของปุ่ มเป็น Image Button และ 

Browse หาภาพปุ่ มท่ีสร้างไว้ โดยเลือกปุ่ มท่ีมีสถานะปกติ โปรแกรมจะทราบวา่เป็นปุ่ มทัง้หมดเป็นชดุ

เดียวกนั และจะน าไปใช้โดยอตัโนมตัิทัง้สามปุ่ ม 

 CHARACTER เป็นการก าหนดเก่ียวกบัตวัอกัษรท่ีอยูบ่นปุ่ ม ส าหรับปุ่ มประเภท Text Button 

 ACTION เป็นค าสัง่ท่ีโปรแกรมมีไว้ให้เลือก ค าสัง่ท่ีส าคญั มีดงันี ้

-Continue  ให้ท าตอ่ไป หวัอ่านจะวิ่งตอ่จากต าแหนง่ปัจจบุนั ถ้ามีวตัถใุดใน slide นัน้ ๆ ท่ีอยู่ตอ่

จากปุ่ มนีไ้ป จะแสดงให้เห็นก่อน และถ้าไมมี่ปุ่ มใด ๆ อีก โปรแกรมจะเปิด slide ถดัไป 

-Go to the previous slide  ให้กลบัไปยงั Slide ท่ีเพิ่งผา่นมา 

-Go to the next slide  ให้ไปยงั Slide ตอ่ไปทนัที ถ้ามีวตัถใุดตอ่จากปุ่ มนีใ้นหน้า Slide นี ้จะไม่

แสดงให้เห็น เพราะโปรแกรมจะข้ามไปยงั Slide ตอ่ไป ทนัที 

-Go to the slide last visited สัง่ให้กลบัไปยงั Slide ท่ีเพิ่งผา่นมา ในกรณีท่ีถกูสัง่ให้กระโดดมา

จาก Slide อ่ืนท่ีไมใ่ช ่Slide ท่ีตดิกนั โปรแกรมจะกลบัไปยงั Slide นัน้ 

-Jump to slide ให้กระโดดไปยงั Slide ใด ๆ ในโปรแกรมนี ้

-Open URL or file  ให้เปิดหน้าเว็บอ่ืน หรือเปิดไฟล์อ่ืน 
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-Open another project .ให้เปิดไฟล์ของ Captivate 5 ในกรณีนี ้ใช้ส าหรับการลิงค์ไฟล์ จากไฟล์

หนึง่ไปอีกไฟล์หนึง่ หรือใช้ส าหรับท าเมน ูเพ่ือลิงค์ไปและกลบัระหว่างไฟล์ได้ 

 OPTIONS  ใช้ส าหรับเปล่ียน Cursor เป็นรูปมือเม่ือเมาส์ลากผา่น หรือให้มีข้อความเพิ่มเตมิ 

 TIMING  ส าหรับตัง้คา่เวลาทัง้หมดท่ีปุ่ มนีจ้ะ

แสดงบนหน้าจอ และเวลาก่อนท่ีปุ่ มจะหยดุหวัอา่นไมใ่ห้

วิ่งตอ่ไป ตลอดจนเวลาหลงัจากเม่ือกดปุ่ มนีไ้ปแล้ว ถ้า

สงัเกตบน Timeline ของปุ่ มจะเห็นมีเส้นขนานแนวตัง้ ซึง่

แสดงเวลา ณ ต าแหนง่ท่ีปุ่ มนีจ้ะท าหน้าท่ีหยดุหวัอ่าน 

ต าแหนง่นี ้สามารถใช้เมาส์ลากเปล่ียนแปลงได้ 

 REPORTING  ในกรณีท่ีเป็นการถามตอบ จะให้น าผลการตอบไปรวมกบัข้อสอบหรือไม ่ถ้าน าไป

รวม จะให้คา่คะแนนของการตอบครัง้นีก่ี้คะแนน 

 AUDIO  ส าหรับเพิ่มเสียงให้แก่ปุ่ ม 

 POSITION & SIZE  ส าหรับก าหนดต าแหนง่และขนาดของปุ่ ม 

 

การใช้เสียงใน Project ของ Captivate 5 

 

เสียงใน Project ของ Captivate 5 สามารถใช้ได้ 3 ลกัษณะ คือ 1)น าเข้าไฟล์เสียงจากภายนอก 

2)บนัทกึเสียงจากไมโครโฟน และ 3)แปลงข้อความเป็นเสียง โดยติดตัง้ Software แปลงข้อความเป็นเสียง 

(Text-to-speech software) เพิ่มเตมิจากแผน่ซีดีของโปรแกรม Captivate  ส าหรับในบทเรียนนี ้จะน าเสนอ

เฉพาะการใช้เสียงจากไฟล์ท่ีน าเข้าเทา่นัน้ 

การใช้เสียงในโปรแกรม Captivate มี 3 ลกัษณะ คือ 1)เสียง Background 2)เสียงประจ า Slide 

และ 3)เสียงประจ าวตัถบุน Slide เชน่ เสียงประกอบปุ่ ม ภาพ หรือ ข้อความ Feedback ในข้อสอบ เป็นต้น 
 

การใช้ไฟล์เสียง 

ไฟล์เสียงท่ีจะน ามาใช้งานได้ คือไฟล์ .wav ของ Microsoft และไฟล์ mp3 ในกรณีท่ีเลือกเสียงท่ี

เป็น wav โปรแกรมจะแปลงให้เป็น mp3 ก่อนการน าเข้ามาใช้งานใน Project 

1. เสียง Background สามารถน าเสียงประกอบเป็น Background ของ Project โดยเสียงจะเลน่ตัง้แตต้่น

จนจบทกุ Slide หากพบว่า มี Slide แผน่ใดมีเสียงอยูใ่น Slide นัน้ เสียงนีจ้ะเบาลง เพ่ือให้ได้ยินเสียง
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ประจ า Slide โดยปกตมิกัจะใช้เสียงเพลงบรรเลง เป็นเสียง Background ประกอบ การใช้เสียง 

Background มีขัน้ตอน ดงันี ้

1.1. เปิด Project ใหม ่หรือใช้ Project ท่ีมีอยูแ่ล้วก็ได้  

1.2. ไปท่ีเมน ูAudio > Import to > Background 

1.3. เลือกไฟล์เสียงจากในเคร่ืองคอมพิวเตอร์  

1.4. จะเปิดหน้าจอ ตอ่ไปนี ้ให้ก าหนดคา่ตามต้องการ 

 
 

1.5. ถ้าต้องการปรับแตง่เสียง ให้คลิกปุ่ ม Edit เพ่ือปรับแตง่เสียงได้ 

1.6. คลิก Close เพ่ือกลบัไปยงัหน้าจอปกต ิ 

1.7. ทดสอบ โดยไปท่ี File > Preview > Project 

1.8. เอาเสียง Background ออก ไปท่ี Audio > Remove > Background 

2. เสียงประจ า Slide เป็นเสียงประกอบ Slide จะเลน่เฉพาะเม่ือ Slide นัน้ ๆ ปรากฏเทา่นัน้ และจะหยดุ

เลน่เม่ือ Slide นัน้ออกไปจากหน้าจอ วิธีการน าเสียงเข้า มีดงันี  ้

2.1. เปิด Project ใหม ่สร้าง Slide เปลา่ จ านวน 3 แผน่ หรือใช้ Project ท่ีมีอยูแ่ล้วก็ได้ ควรมี Slide 

จ านวน 3-4 แผน่ 

2.2. คลิกเลือกแผน่ Slide ท่ี 1 

2.3. ไปท่ีเมน ูAudio > Import to > Slide 

2.4. เลือกไฟล์เสียง mp3 จากในเคร่ืองคอมพิวเตอร์  

2.5. การน าเข้าในแผน่ Slide มีลกัษณะ ดงันี ้
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 ถ้า Project นัน้ มี Slide แผน่เดียว หรือ Slide ท่ีจะน าเสียงเข้านัน้ เป็น Slide แผน่สดุท้าย 

โปรแกรมจะน าเสียงเข้าทนัที และถ้าความยาวของ Slide น้อยกวา่ ความยาวของเสียง 

โปรแกรมจะขยายความยาวของ Slide ให้เทา่กบัเสียง 

 ถ้า Project นัน้มีแผน่ Slide หลายแผน่ และ Slide ท่ีน าเสียงเข้า ไมใ่ชแ่ผน่สดุท้าย และ Slide 

นัน้ มีความยาวมากกว่าไฟล์เสียง โปรแกรมจะน าเสียงเข้าท่ี Slide นัน้ตามปกติ โดยจะ

ปรากฏหน้าจอให้ปรับแตง่เสียงได้ ก่อนน าเข้า ดงันี  ้

 
 

หน้าจอนี ้สามารถปรับแตง่เสียงได้ เม่ือคลิก Close โปรแกรมจะน าเสียงเข้า Slide ทนัที 

 ถ้า Project นัน้มีแผน่ Slide หลายแผน่ และ Slide ท่ีน าเสียงเข้า ไมใ่ชแ่ผน่สดุท้าย แต ่Slide 

นัน้ มีความยาวน้อยกว่าไฟล์เสียง โปรแกรมจะให้เลือกลกัษณะท่ีน าเสียงเข้า 3 ลกัษณะ

ดงันี ้

 
 

1) น าเสียงเข้าท่ี Slide นัน้ และจะขยายความยาวของ Slide นัน้ให้เทา่กบัความยาวของเสียง 

2) เฉล่ียเสียงออกตามจ านวน Slide ท่ีเหลือ โดยจะน าเสียงทัง้หมดเข้าใน Slide ท่ีเลือกก่อน 

จากนัน้ จะเปิดหน้าจอให้ปรับวา่จะน าเสียงไปไว้ Slide แผน่ใด อยา่งไร ดงัภาพ 
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การเฉล่ีย ท าโดยลากเส้นแบง่ขอบเขตของ Slide แตล่ะแผ่น เข้าไปในบริเวณเสียง ดงัภาพ 

3) รักษาความยาวของ Slide ท่ีเลือกไว้เหมือนเดมิ แตเ่ฉล่ียเสียงออกไปตาม Slide ท่ีเหลือ 

ข้อควรระวัง เม่ือน าเสียงท่ีมีความยาวมากกวา่ ความยาวของ Slide เข้า Slide แล้ว ให้ตรวจสอบ

ต าแหนง่ของวตัถตุา่ง ๆ ท่ีมีอยูก่่อนน าเสียงเข้า และเล่ือนปรับต าแหนง่ของวตัถตุา่ง ๆ ให้เหมาะสม  

2.6. ถ้าต้องการเอาเสียงประจ า Slide ออก ให้ไปท่ี Audio > Remove > Slide 

 

3. เสียงประจ าวตัถบุน Slide 

เสียงสามารถน าเข้ากบัวตัถ ุเชน่ ภาพ ข้อความ ได้ โดยเฉพาะ ข้อความท่ีใช้เป็น Feedback 

ส าหรับข้อสอบ ก็สามารถน าเสียงเข้าได้ เชน่กนั วิธีการน าเข้าเสียงประจ าวตัถ ุมีดงันี  ้

3.1. เปิด Project ใหม ่

3.2. น าเข้าภาพ โดยไปท่ี Insert > Image … และเลือกภาพท่ีต้องการ 

3.3. คลิกท่ีภาพ  

3.4. ท่ีแถบ PROPERTIES คลิกเปิดแถบ AUDIO และคลิก Add Audio… 

 

3.5. โปรแกรมจะเปิดหน้าจอให้เลือกและปรับแตง่ไฟล์เสียง 
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3.6. คลิกปุ่ ม Import เพ่ือเลือกไฟล์เสียง  

3.7. โปรแกรม Captivate มีเสียงประกอบเตรียมไว้ให้เลือก อยูใ่นห้องโปรแกรมของ 
Captivate/Gallery/Sound/ 

3.8. ถ้าต้องการปรับแตง่ ให้คลิกแถบ Edit 

3.9. จากนัน้ให้กดปุ่ ม Save และ Close ตามล าดบั โปรแกรมจะกลบัมาท่ีหน้าจอเดมิ 

3.10. ทดสอบโดยไปท่ี File > Preview > Project 

การใช้คลิปวิดีโอ ใน Project ของ Captivate 5 

 

โปรแกรม Captivate สามารถน าเข้าไฟล์วิดีโอ AVI, MOV, FLV และ MPEG โดยสามารถ Sync 

ภาพ และเสียงได้จากใน Slide ตา่ง ๆ โดยปกติ สามารถใช้ไฟล์วิดีโอใน Slide ทัว่ ๆ ไปได้ แตมี่ Slide 

บางอย่างท่ีไมส่ามารถใช้วิดีโอได้ เชน่ Slide แมแ่บบของข้อสอบ Random Slides หรือ Slide ท่ีถกู Lock ไว้ 

เป็นต้น 

การน าเข้าวิดีโอ สามารถน าเข้า 2 ทาง ได้แก่ 1)น าเข้าทางเมน ูVideo > Insert Slide Video…หรือ 

เมน ูInsert > Slide Video… และ  2) น าเข้าทางเมน ูInsert > FLV or F4V File… ซึง่มีข้อแตกตา่งกนัคือ 

น าเข้าทาง Insert Slide Video น าเข้าทาง FLV or F4V File 

สามารถ Sync กบัแผ่น Slide ได้ ไมส่ามารถ Sync กบัแผน่ Slide ได้ 

เพิ่มข้อมลูลงใน Library สามารถดไูด้จากใน Library ไมเ่พิ่มข้อมลูใน Library 

มีปุ่ มบงัคบัวิดีโอโดยเฉพาะ ไมมี่ปุ่ มบงัคบัวิดีโอ วิดีโอขึน้อยูก่บั Slide 

 
 

1. การน าเข้าวิดีโอ ทาง Insert Slide Video 

การน าเข้าวิดีโอ สามารถให้เลน่ภายใน Slide แผน่เดียว หรือ เฉล่ียไปหลายแผ่น ก็ได้ และสามารถ

น าเข้าได้ทัง้ผา่นทางเมน ูInsert > Slide Video… หรือผา่นทางเมน ูVideo ก็ได้ 
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1.1. คลิกท่ี Slide ท่ีต้องการน าเข้าวิดีโอ และไปท่ี Insert > Slide Video… 

1.2. เลือก วิดีโอ ท่ีต้องการ 

1.3. ถ้า Slide นัน้มีแผน่เดียว หรือเป็นแผน่สดุท้าย โปรแกรมจะน าวิดีโอเข้า และขยายความยาวของ 

Slide ออกไป 

1.4. ถ้า Slide นัน้ไมใ่ช ่Slide สดุท้าย และความยาวน้อยกว่าความยาวของวิดีโอ จะมีหน้าจอให้เลือก

ลกัษณะการน าเข้า 

 

- น าวิดีโอทัง้หมดวางไว้ใน Slide ท่ีเลือกเพียง Slide เดียว  

- รักษาความยาวของ Slide ท่ีเลือกไว้ และเฉล่ียวิดีโอท่ีเหลือไปยงั Slide อ่ืน ๆ 

ข้อควรระวัง เม่ือน าวิดีโอท่ีมีความยาวมากกวา่ ความยาวของ Slide เข้า Slide แล้ว ให้ตรวจสอบ

ต าแหนง่ของวตัถตุา่ง ๆ ท่ีมีอยูก่่อนน าวิดีโอเข้า และเล่ือนปรับต าแหนง่ตา่ง ๆ ให้เหมาะสม  

1.5. ถ้าต้องการลบวิดีโอออกจาก Slide ให้ไปท่ี เมน ูVideo > Video Management … คลิกเลือกวิดีโอท่ี

ต้องการลบ แล้วคลิกท่ีถงัขยะ 

1.6. ถ้าต้องการปรับความยาวของวิดีโอในแตล่ะ Slide ให้ไปท่ี .เมน ูVideo > Video Management … 

คลิกเลือกวิดีโอท่ีต้องการ และคลิกรูปดนิสอ 

1.7. จะเกิดหน้าจอให้แก้ไข โดยลากปรับเส้นขอบเขตของ Slide ตามต้องการ 

 
 

เส้นแบง่ขอบเขต Slide 
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2. การน าเข้าวิดีโอ ทาง Insert > FLV or F4V File 

2.1. สร้าง Slide ใหม ่

2.2. ไปท่ีเมน ูInsert > FLV or F4V File 

2.3. จะเปิดหน้าจอให้ import วิดีโอ ให้คลิก Browse เลือกไฟล์วิดีโอจากในคอมพิวเตอร์ หรือ เลือก

จากบนอินเทอร์เน็ต โดยระบใุนชอ่ง URL 

 

2.4. คลิกปุ่ ม OK 

2.5. จะกลบัมาท่ีหน้าจอเดมิ ถ้าวิดีโอมีขนาดใหญ่เกินกวา่ Slide ให้ลากเพ่ือปรับขนาดให้เหมาะสม 

2.6. ทดสอบ ไปท่ี File > Preview > Project 

2.7. ถ้าต้องการลบ ให้คลิกท่ีวิดีโอบนแผ่น Slide และคลิกปุ่ ม Delete บนแป้นพิมพ์ 

 

การสร้างข้อสอบ 

 

โปรแกรม Captivate 5 สามารถสร้างข้อสอบได้หลายชนิด เชน่ แบบเลือกตอบ แบบจบัคู ่แบบ

เรียงล าดบั แบบเตมิค าสัน้ ๆ และสามารถจดัท าข้อสอบแบบสุม่ตามจดุประสงค์ได้ ข้อสอบทกุชนิดมี

แมแ่บบเตรียมไว้ให้พร้อมใช้งาน นอกจากนีย้งัมีการเก็บคะแนน การสง่คะแนนออกไปยงัระบบ LMS ท่ีมี

มาตรฐาน Scorm 1.2 หรือ 2004 เชน่ Moodle หรือ Blackboard เป็นต้น อีกทัง้ยงัสามารถสง่คะแนนไปท่ี

ตา่ง ๆ เชน่ เว็บไซต์ Acrobat.com, Adobe Acrobat Connect Pro, สง่คะแนนทางอีเมล หรือ ให้เก็บคะแนน

ลงเคร่ืองคอมพิวเตอร์ ได้ 

เน่ืองจากโปรแกรม Captivate ออกแบบส าหรับใช้บนอินเทอร์เน็ต โดยเฉพาะกบัระบบ LMS 

ดงันัน้จงึมีข้อจ ากดัท่ีควรทราบคือ 
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- ไฟล์ 1 ไฟล์จะสง่คะแนนออกเพียงชดุเดียวเท่านัน้ หากต้องการเก็บคะแนนก่อนเรียน 

(Pretest) และคะแนนหลงัเรียน (Posttest) ต้องแยกไฟล์ เป็น 2 ไฟล์ 

- การเก็บข้อมลูลงบนเคร่ืองคอมพิวเตอร์ไมส่ามารถท าได้ตามปกต ิต้องท าให้เคร่ือง

คอมพิวเตอร์เป็น Server เสียก่อน จากนัน้ จงึใช้โปรแกรมรับคะแนนท่ีสง่ออกจาก 

Captivate และเก็บลงฐานข้อมลู 

ส าหรับในบทเรียนนี ้จะน าเสนอการสร้างข้อสอบแบบเลือกตอบ และแบบจบัคู ่เทา่นัน้ สว่นการ

รายงานผลคะแนนจะให้จดัเก็บคะแนนลงเคร่ืองคอมพิวเตอร์ 

 

1. การสร้างข้อสอบแบบเลือกตอบ มีขัน้ตอน ดงันี ้

1.1. เปิด Project ใหม ่ไปท่ี File > New Project > Blank Project 

1.2. เน่ืองจากแมแ่บบท่ีโปรแกรมเตรียมไว้ให้เป็นภาษาองักฤษ เชน่ ข้อความท่ีเป็น Feedback ตา่ง ๆ 

ดงันัน้จงึต้องปรับแก้เป็นภาษาไทยเสียก่อน (ถ้าท าข้อสอบแล้วมาปรับแก้ภายหลงั โปรแกรมจะไม ่

Update ให้ ข้อความตา่ง ๆ จะเป็นภาษาองักฤษทัง้หมด) 

1.3. ปรับแก้ข้อความเป็นภาษาไทย 

 ไปท่ี เมน ูQuiz > Quiz Preferences…  

 เม่ือเปิดหน้าจอ Preferences .ให้ดท่ีู Category > Quiz เลือก Default Labels และปรับแก้ให้

เป็นภาษาไทย เชน่ 

 
 

 ในขณะแก้ไขให้สงัเกตการแสดงผลในชอ่ง Style Preview ด้วย 
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 เสร็จแล้วคลิกปุ่ ม OK 

1.4. ถ้าต้องการเก็บคะแนน ให้ตัง้คา่การรายงาน โดยคลิกท่ี Reporting ในสว่นของ Quiz และคลิกใน

กลอ่งหน้าข้อความ Enable reporting for the project เพ่ือก าหนดให้มีการรายงานผล 

 

จากหน้าจอนี ้จะพบว่าสามารถรายงานผลได้หลายทาง ถ้าใช้กบัระบบ LMS ให้เลือก 

Standard และก าหนดคา่ตา่ง ๆ ตามต้องการ แตใ่นบทเรียนนี ้จะเป็นการเก็บคะแนนลงบนเคร่ือง

คอมพิวเตอร์ ให้คลิกเลือกการสง่ไปท่ี Internal Server และคลิก Configure… เพ่ือก าหนดคา่ท่ีจ าเป็น 

 
 

ทา่นต้องเตมิข้อความทกุช่องในหน้าจอนี ้ข้อมลูนี ้Captivate จะสง่ตอ่ไปยงั Server เพ่ือเก็บลงใน

ฐานข้อมลู พร้อมกบัข้อมลูอ่ืน ๆ ท่ี Captivate เก็บรวบรวมไว้ขณะท าข้อสอบ เชน่ เวลาท าข้อสอบ คะแนน

การสอบ จ านวนครัง้ท่ีท า เป็นต้น เม่ือเตมิข้อความเสร็จแล้วให้คลิกปุ่ ม Save 

Server: ต าแหนง่ของไฟล์บน Server ท่ีจะรับข้อมลูผลการสอบไปเก็บ ถ้าไฟล์อยู่บน

อินเทอร์เน็ต ให้ระบ ุURL เชน่ http://www.crnfe.ac.th/cp5/... แตถ้่าเป็นการ
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เก็บผลการสอบลงบนเคร่ืองคอมพิวเตอร์ของผู้ใช้ โดยปกตจิะเป็น 

http://localhost/... (ดรูายละเอียดเร่ือง การติดตัง้ Server ด้วย Xampp และ

เร่ืองการสร้างห้องเสมือน (Virtual directory) เพ่ือเก็บผลการสอบบน Server) 

Company/Institute: ช่ือโรงเรียน หรือหนว่ยงาน 

Department: ช่ือแผนก หมวดวิชา หรือส่วนท่ีเก่ียวข้อง 

Course: ช่ือรายวิชาของข้อสอบชดุนี ้

1.5. เปิดแมแ่บบข้อสอบ โดยไปท่ี Quiz > Question Slide… 

 

1.6. เลือก Multiple Choice จ านวน 1 ข้อ และเลือก Graded ในกรณีท่ีจะมีการเก็บคะแนน  

1.7. แม้วา่โปรแกรม Captivate 5 เตรียมแมแ่บบให้สามารถเลือกสร้างข้อสอบแตล่ะชนิดได้ครัง้ละ

หลายข้อ แตแ่มแ่บบส าหรับ Multiple Choice ก าหนดตวัเลือกท่ีเป็นคา่เร่ิมต้น (Default) ไว้เพียง 2 

ตวัเลือก ท าให้ต้องเสียเวลาปรับคา่ใน Properties ทกุข้อ ดงันัน้ ถ้าก าหนดไว้เพียงข้อเดียวก่อน 

และไปปรับแตง่ลกัษณะในแถบ Properties แล้วจงึ Duplicate ทัง้ Slide จะท างานได้เร็วกวา่ 

1.8. คลิกปุ่ ม Ok จะเห็นวา่ โปรแกรมสร้าง Slide เพิ่มให้ 2 แผน่ แผน่แรกเป็นตวัข้อสอบ แผน่ท่ี 2 เป็น

การรายงานผล ดงัภาพ 
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1.9. ท่ีแถบ QUIZ PROPERITES ให้ก าหนดจ านวนตวัเลือก (Answers) และ คะแนนส าหรับข้อนี ้(Points) 

ตามต้องการ ในตวัอยา่ง ก าหนดให้เป็น 4 ตวัเลือก และถ้าท าถกู ได้ 1 คะแนน 

 
 

1.10. ส าหรับการล าดบัหวัข้อของตวัเลือก โปรแกรม Captivate 5 ก าหนดมาให้แล้ว เป็นระบบ 

A,B,C หรือ ระบบตวัเลข เทา่นัน้ ไมส่ามารถปรับเป็น ก. ข. ค. ได้ ต้องเลือกใช้ตามท่ีโปรแกรม

ก าหนด (คาดวา่ รุ่นตอ่ ๆ ไป อาจจะสามารถปรับสว่นนีใ้ห้เป็นภาษาไทยได้) 

1.11. พิมพ์ข้อความ หรือน าภาพเข้า ตามต้องการ 

1.12. ทดสอบ โดยไปท่ี File > Preview > Project 

 

2. การสร้างข้อสอบแบบ จบัคู ่มีวิธีดงันี ้

2.1. เปิด Project ใหม ่หรือสามารถท าตอ่จากข้อสอบแบบ Multiple Choice ท่ีท าไว้แล้วก็ได้ 

2.2. ถ้าท าตอ่จากข้อสอบท่ีแล้ว ไมต้่องปรับแก้ข้อความ ใน Quiz preferences ถ้าเร่ิม Project ใหม ่

ต้องปรับแก้ข้อความใน Quiz preferences ให้เป็นภาษาไทยก่อน ทกุครัง้ 

2.3. ไปท่ี Quiz > Question Slides เลือก Matching ก าหนดจ านวนข้อของข้อสอบท่ีต้องการแล้วคลิก 
OK 

 

2.4. จะเปิดหน้าจอแมแ่บบข้อสอบแบบเลือกตอบ 
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2.5. ก่อนพิมพ์ให้ปรับคา่ใน QUIZ PROPERTIES ตามต้องการ 

 

แถบ GENERAL 

Type: ประเภทเก็บคะแนน (Graded) หรือ เป็นแบบสอบถาม (Survey) ไมเ่ก็บ

คะแนน 

Column 1: จ านวนข้อในคอลมัน์ท่ี 1 ด้านซ้ายมือ 

Column 2 : จ านวนข้อในคอลมัน์ท่ี 2 ด้านขวามือ 

Shuffle Column 1: ก าหนดให้มีการสลบัข้อในคอลมัน์ท่ี 1 หรือไม ่ถ้าก าหนดให้

มีการสลบัข้อ จะสลบัข้อใหม่ทกุครัง้ท่ีเปิดเพ่ือท าข้อสอบ 

Points: คา่คะแนนของข้อสอบชดุนี ้ผู้ เรียนต้องท าทกุข้อถกูหมดจงึจะได้คะแนน  

Numbering: ตวัเลขหวัข้อ ให้เลือกจากท่ีก าหนดให้ เป็นระบบตวัเลข 
 

แถบ OPTIONS 

Captions: ข้อความ Feedback ท่ีต้องการให้แสดงในหน้านี ้ถ้าไมแ่ก้ไขใน Quiz 

Preferences ก่อน ข้อความจะเป็นคา่ Default ซึง่เป็นภาษาองักฤษ 
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Tim Limit: จ านวนเวลาท่ีก าหนดให้ท าในข้อนี ้

Buttons: ปุ่ มท่ีต้องการให้แสดงบนหน้านี ้ถ้าไมแ่ก้ไขใน Quiz Preferences ก่อน 

ข้อความบนปุ่ มจะเป็นคา่ Default ซึง่เป็นภาษาองักฤษ 

2.6. พิมพ์ข้อสอบ ถ้าต้องการใช้ภาพ สามารถน าภาพเข้าได้ตามปกติ (เมน ูInsert > Image…) 

2.7. เม่ือเสร็จแล้ว ให้ทดสอบ ไปท่ี File > Preview > Project 

 

3. การสร้างข้อสอบแบบสุม่ 

ข้อสอบแบบสุม่ เป็นข้อสอบท่ีมีการสุม่ข้อสอบแตล่ะข้อจากข้อสอบจ านวนหนึง่ เชน่ข้อสอบข้อท่ี 

1 สุม่มาจากข้อสอบ จ านวน 5 ข้อ ซึง่เป็นข้อสอบท่ีมีความยากง่ายเท่ากนั หรืออยูใ่นจดุประสงค์เดียวกนั 

เป็นต้น 

วิธีการสร้างข้อสอบแบบสุม่ จงึต้องมีการสร้างกลุม่ของข้อสอบเสียก่อน เพ่ือให้สุม่ในแตล่ะกลุม่

มาเพียงใช้งานแตล่ะครัง้เพียงข้อเดียว การจดักลุม่ อาจจะจดัตามวตัถปุระสงค์ของรายวิชา ก็ได้ เพ่ือให้

แนใ่จวา่ ข้อสอบครอบคลมุทกุจดุประสงค์ 

โปรแกรม Captivate เรียกแตล่ะกลุม่วา่ เป็น Pool ซึง่หมายถึงการน าเอาข้อสอบมารวมกนัไว้ในท่ี

เดียวกนั ก่อนท่ีจะสุม่มาใช้งาน 

ขัน้ตอนการสร้าง มี 2 ขัน้ตอน คือ การสร้าง Pool ของข้อสอบ และการสุม่จาก Pool ข้อสอบมาใช้

งาน 

3.1. การสร้าง Pool ข้อสอบ 

 ไปท่ี QUIZ > Question Pool Manager… 

 จะเปิดหน้าจอ Pool Manager ให้คลิกเคร่ืองหมายบวกเพ่ือสร้างข้อสอบใน Pool1 

 

 จะเกิดหน้าจอให้สร้างข้อสอบ ให้สร้างข้อสอบเทา่กบัจ านวนท่ีต้องการ 
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 ถ้ามี Slide ข้อสอบอยูแ่ล้ว สามารถคลิกขวาท่ี Slide และย้ายมาท่ี Pool ได้ 

 

 ถ้าเคยสร้าง Pool ไว้แล้วในไฟล์อ่ืน สามารถน าเข้ามาใช้งานได้ โดยคลิกท่ี เมน ูQUIZ > Import 

Question Pools… 

 

จากนัน้ให้คลิก Browse ไปยงัไฟล์ท่ีมี Question Pool ท่ีเคยสร้างไว้ และเลือกน าเข้า Pool ท่ี

ต้องการ 

 ถ้าต้องการเปล่ียนช่ือ Pool1 ให้คลิกขวา และเปล่ียนช่ือใหม่ 

 

 ถ้าต้องการลบ Pool หรือ ข้อสอบ ให้คลิกเลือกก่อน และคลิกเคร่ืองหมายลบ 

3.2. การสุม่ข้อสอบ จาก Pool  

 ไปท่ีเมน ูQUIZ > Random Slide 

 เลือก Pool ท่ีต้องการจากในแถบ QUIZ PROPERTIES > GENERAL 
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 จะได้ข้อสอบ 1 ข้อจาก Pool ท่ีเลือก ให้ท าเชน่นีก้บั Pool อ่ืน ๆ จนได้ข้อสอบตามจ านวนท่ี

ต้องการ ข้อสอบ Pool เดยีวกนั ห้ามน ามาใช้ซ า้กนั เพราะมีโอกาสท่ีข้อสอบจะซ า้กนัได้ 

 

4. การรายงานผลคะแนน 

4.1. การเก็บคะแนนท่ี Acrobat.com 

             เม่ือผู้ เรียน/ผู้ใช้ท าข้อสอบเสร็จแล้ว สามารถเก็บคะแนนไว้ท่ี http://www.acrobat.com ได้ โดยไม่

เสียคา่ใช้จา่ย แตจ่ะต้องก าหนดให้เก็บข้อมลูการสอบไว้ท่ี Acrobat.com เสียก่อน เม่ือผู้ใช้ท าข้อสอบแล้ว 

จะมีปุ่ มให้เลือกเก็บคะแนนไว้บน Acrobat.com โดยผู้ เรียนต้องมี Adobe ID ด้วย จงึจะสามารถเก็บคะแนน

ได้ Adobe ID จะมีลิงค์อยูแ่ล้วในหน้าจอการสง่คะแนน ผู้ เรียนสามารถขอ Adobe ID ได้ฟรีเชน่กนั  

การก าหนดให้เก็บคะแนนบน Acrobat.com มีวิธีการดงันี ้

1. ไปท่ี http://www.acrobat.com  และลงทะเบียน สร้าง Adobe ID 

2. ท่ี Captivate ไปท่ี Edit > Preferences… 

3. เลือก Quiz  เลือก Quiz: Enable reporting for this project 

 

4. เลือก Acrobat.com 

 

5. ระบ ุReport Status เป็นแบบ Pass/Fail  

 

6.  ท่ี Acrobat.com คลิก Configure… 
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7. กรอกข้อมลูโดยใช้ Adobe Id และ Password ของเจ้าของวิชา ถ้ายงัไมมี่ สามารถคลิก

ลิงค์ไปยงัหน้าเว็บของ Acrobat.com เพ่ือขอ id ได้ 

 

8. Company/Institution ให้เขียนเป็นภาษาองักฤษ ระบช่ืุอ สถานศกึษา/โรงเรียน 

9. Department ให้ระบช่ืุอ แผนก/หมวดวิชา ให้ระบเุป็นภาษาองักฤษ 

10. Course ให้ระบ ุช่ือ Course เป็นภาษาองักฤษ ในกรณีท่ีใน Course นี ้มีหลายบทเรียน 

(lesson) ให้ระบช่ืุอ Course เป็นช่ือเดียวกนั Acrobat.com จะน าช่ือไฟล์ เป็นช่ือ

บทเรียน (lesson)แตล่ะบทเรียน ในแตล่ะบทเรียน (lesson) จะมีข้อสอบเพียงชดุเดียว

เทา่นัน้ ทัง้นี ้ในการแสดงผลการสอบ Acrobat.com จะน าช่ือบทเรียนไปแสดงให้เลือก

ภายใต้ช่ือ Course ท่ีระบ ุ 

11. เม่ือสร้างข้อสอบเสร็จแล้ว ให้ Publish ตามปกติ 

12. เม่ือผู้ เรียน/ผู้ใช้ ท าข้อสอบเสร็จแล้ว โปรแกรมจะมีปุ่ มให้ส่งผลการสอบ 

 

13. ผู้ใช้/ผู้ เรียน ต้องกรอกข้อมลู ถ้าไมมี่ AdobeID ต้องลงทะเบียนก่อน โดยคลิกสมคัร

ตามลิงค์ ฟรี ไมเ่สียคา่ใช้จา่ย และน า Id และ Password มาใสไ่ว้ท่ีน่ี 

 

14. หน้าจอนีจ้ะท างานในขณะท่ีอยูใ่นระหวา่งการแก้ไข สามารถทดสอบได้ แตถ้่า 

Publish แล้ว ต้องน าขึน้ Server บนอินเทอร์เน็ต หรือน าไฟล์ทัง้หมดไปไว้ใน ห้อง
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เสมือน (http://localhost /… ) ในเคร่ือง จงึจะสามารถสง่ข้อมลูของผู้ เรียนได้ไปยงั 

Acrobat.com ได้  

15.  การดคูะแนนผลการสอบ ให้ใช้โปรแกรม Adobe Captivate Quiz Results Analyzer 

ซึง่ตดิตัง้มาให้พร้อมกบัโปรแกรม Adobe Captivate และ Sign in โดยใช้ช่ือและรหสั

ตามท่ีเคยใช้ในข้อ 7 

 

16. เม่ือเข้าสูห่น้าจอ แล้ว ให้เลือก Course ท่ีต้องการ 

 

17. จากนัน้ให้กด Generate Report 

 

18. ในกรณีท่ี Course นีมี้หลายบทเรียน (lessons) Acrobat.com จะน าช่ือไฟล์มาแสดง

เป็นช่ือแบบฝึกหดัมาแสดงให้เลือก ถ้ามีบทเรียนเดียว จะเห็นเพียงบทเรียนเดียว 

 

19. เลือกบทเรียน (lesson) ท่ีต้องการ โดยการดบัเบิล้คลิกท่ีช่ือบทเรียน 
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20. ถ้าต้องการดรูายละเอียดของผู้สอบแตล่ะคน ให้ดบัเบิล้คลิกท่ีช่ือของผู้ เรียนผู้นัน้ 

 

21. ถ้าต้องการดภูาพรวมทัง้ Course ให้คลิกท่ีช่ือ Course 

 

22. ถ้าต้องการให้แสดงกราฟ ให้คลิกท่ี ไอคอนกราฟ (กราฟจะแสดงเฉพาะในระดบั 

Course เทา่นัน้) 

 
 

4.2. การรายงานผลคะแนนลงบนเคร่ืองคอมพิวเตอร์ 

การรายงานผลคะแนนลงบนเคร่ืองคอมพิวเตอร์ ต้องปรับเคร่ืองคอมพิวเตอร์ให้เป็น Server 

เสียก่อน สามารถท าได้โดยการติดตัง้โปรแกรม เชน่ Xampp หรือ Appserv ซึง่เป็นโปรแกรม Open source 

ส าหรับในบทเรียนนี ้เลือกใช้ Xampp เน่ืองจากตดิตัง้ง่าย ไมซ่บัซ้อน ใช้งานง่าย และมีครบทัง้ Server ท่ีเป็น
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Apache ฐานข้อมลู MySql โปรแกรม PHP และ โปรแกรม PhpMyAdmin ส าหรับชว่ยท างานกบัฐานข้อมลู

ให้ง่ายขึน้ 

การรับคะแนนท่ีสง่ออกมาจาก Captivate ในกรณีท่ีสัง่ให้เก็บคะแนนลงบนเคร่ืองคอมพิวเตอร์ 

จ าเป็นต้องเขียนโปรแกรมส าหรับรับคะแนนท่ีสง่ออกมา ในบทเรียนนี ้ใช้โปรแกรม PHP ได้จดัท าขึน้และ

สามารถน าไปแก้ไขปรับปรุงได้ตามต้องการ คะแนนท่ีเก็บจะเก็บลงฐานข้อมลู MySql ท่ีระบบ Xampp 

ตดิตัง้ให้แล้ว 

4.3. การติดตัง้ Server ด้วย Xampp 

Xampp เป็นโปรแกรมส าหรับตดิตัง้ Server ลงบนเคร่ืองคอมพิวเตอร์ ซึง่ประกอบด้วย Apache web 

server, MySql, PHP และ Perl เป็นโปรแกรมฟรี ส าหรับ Windows ดาวน์โหลดได้ท่ี 

http://www.apachefriends.org/en/xampp-windows.html แนะน าให้ดาวน์โหลด Xampp Lite ท่ีเป็นไฟล์ 

EXE เน่ืองจากไฟล์มีขนาดเล็ก เพียงพอแก่การใช้งานท่ีต้องการ และติดตัง้ง่าย 

 

วิธีการตดิตัง้ Server ด้วย Xampp 

หลงัจากดาวน์โหลดโปรแกรมมาแล้ว ให้ดบัเบิล้คลิกท่ีไฟล์ EXE ท่ีดาวน์โหลด โปรแกรมจะตดิตัง้ให้ 

Sever และ ไฟล์อ่ืน ๆ ให้โดยอตัโนมตัิ รอจนกระทัง่โปรแกรมท างานเสร็จ จะพบว่ามี ไอคอนของ Xampp (

) ปรากฏท่ีหน้าจอ ให้คลิกเพ่ือเปิดเมนแูละเปิดให้ Server ท างาน 

 

ให้คลิกเปิด Apache และ MySql  

 

ทดสอบโดยเปิด Browser และพิมพ์ http://localhost/ จะพบหน้าจอข้างลา่งนี ้แสดงว่า โปรแกรม

ท างานเรียบร้อย และเคร่ืองของทา่นมีสถานะเป็น Sever เรียบร้อยแล้ว 



32 

 

 

 

4.4. การสร้างห้องเสมือน (Virtual directory) เพ่ือเก็บผลการสอบบน Server  

บน Server ห้องหรือ Folder ท่ีสามารถเข้าถึงได้โดยผา่น Browser เรียกวา่เป็น Virtual directory 

โดยไฟล์จะมีท่ีอยูจ่ริง ซึง่เป็น Physical directory อยู่บนเคร่ืองคอมพิวเตอร์ ถ้าติดตัง้โปรแกรม Xampplite 

ใน Drive C บน Windows ท่ีอยูจ่ริงของไฟล์ท่ีจะใช้เรียกใช้ผา่นทาง Browser คือ c:\xampplite\htdocs\ 

ดงันัน้ จงึต้องสร้างห้องในห้อง htdocs เพ่ือเก็บผลการสอบ ห้องนี ้

ถ้าทา่นตดิตัง้โปรแกรม Xampplite ท่ี Root ของ Drive C ให้สร้างห้องช่ือ cp5 ในห้อง htdocs ดงันี ้

c:\xampplite\htdocs\cp5 ห้องนีส้ามารถเข้าถึงโดยผา่น Browser ท่ี http://localhost/cp5/ 

4.5. การเก็บคะแนนจาก Captivate 5 ลงฐานข้อมลู MySql 

 ไฟล์ส าหรับเก็บคะแนน  

สถาบนั กศน. ภาคกลาง ได้พฒันาโปรแกรมส าหรับเก็บข้อมลูลงบนฐานข้อมลู MySql โดย

ใช้ช่ือวา่ crnfe.php ให้ทา่นคดัลอกและวางไฟล์นี ้ในห้องท่ีสร้างขึน้ เชน่ ถ้าสร้างห้อง cp5 จะ

เป็นดงันี ้c:\xampplite\htdocs\cp5\crnfe.php (โค้ดของไฟล์ อยูใ่นภาคผนวก) 

 การสร้างฐานข้อมลูและตารางในฐานข้อมลู ใ 

ในการเก็บข้อมลูต้องมีฐานข้อมลูและตารางส าหรับเก็บข้อมลู ในตวัอยา่งตอ่ไปนี ้จะเป็นการ

สร้างฐานข้อมลู และตารางส าหรับใช้งานกบัไฟล์ crnfe.php 

- ให้เปิด Browser และพิมพ์ http://localhost/ และกด Enter 

- ภายใต้หวัข้อ Tools ให้เลือก phpMyAdmin 
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- สร้างฐานข้อมลูใหม่ ตัง้ช่ือตามความเหมาะสม ในตวัอย่างช่ือ scorecp5 

 

- สร้างตารางใหม่ ช่ือ score โดยมีฟิลด์ จ านวน 7 ฟิลด์ ดงันี ้

o id    INT(14) Auto-increment, Primary Key 

o stName   varchar(100) 

o courseName  varchar(60) 

o score   varchar(100) 

o dateTaken  varchar(100) 

o beginTime  varchar(10) 

o totalTime  varchar(10) 

หมายเหต ุช่ือฟิลด์สะกดให้ถกูต้องตามตวัอกัษรตวัเล็ก-ตวัใหญ่ 

 

 

 การการปรับคา่ (Config) ในโปรแกรม Captivate 5 

ในการใช้งาน ต้องปรับคา่ใน Internal Server ของ Preferences  
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 ไปท่ีเมน ูQUIZ > QUIZ PREFERENCES > QUIZ > Reporting คลิก Enable reporting for this 

project เลือก Internal Server และคลิกปุ่ ม Configure 

 พิมพ์ข้อมลูดงัภาพ 

 
 

Server: http://localhost/cp5/crnfe.php 

Company/Institute: ช่ือหนว่ยงานของทา่น 

Department: ช่ือแผนก/ภาควิชา/สว่นงาน 

Course: ช่ือรายวิชา หรือช่ือข้อสอบชดุนี ้

4.6. การแสดงผลคะแนน 

สถาบนั กศน.ภาคกลาง ได้พฒันาโปรแกรมเพ่ือดผูลการสอบ ช่ือ showscore.php ให้คดัลอกไฟล์

นีไ้ว้ในห้อง cp 5 ท่ีสร้างขึน้ สามารถใช้งานได้ 2 ลกัษณะ คือ 

 เรียกใช้โดยตรง ผา่น Browser โดยพิมพ์ http://localhost/cp5/showscore.php ท่ีชอ่ง 
Address bar 

 

 สร้างปุ่ มในข้อสอบ และก าหนด Action ของปุ่ ม On success: เลือก Open URL or File และ ท่ี

ชอ่ง URL ให้ระบท่ีุอยูข่องไฟล์เป็น http://localhost/cp5/showscore.php   
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 เม่ือ Preview ดแูละคลิกปุ่ มนี ้จะเปิด Browser  และแสดงคะแนนจากฐานข้อมลูในเคร่ือง

คอมพิวเตอร์ 

 

การส่งออก (Publish) เพื่อใช้งาน 

 

เม่ือจดัท าโปรแกรมด้วย Captivate เสร็จแล้ว และจะน าไปใช้งานต้องสง่ออกไฟล์เสียก่อน 

โปรแกรม Captivate สง่ออกได้หลายลกัษณะ เชน่  

- สง่ออกเป็น swf ส าหรับน าไปใช้งานบนอินเทอร์เน็ตผา่นทาง Browser หรือใช้งานบน

เคร่ืองคอมพิวเตอร์ ทางโปรแกรมพิเศษส าหรับเลน่ swf เชน่ SWF & FLV Player เป็นต้น 

- สง่ออกเป็น exe สามารถน าไปใช้เลน่บนเคร่ืองคอมพิวเตอร์ได้ทนัที ด้วยตวัเอง โดยไม่

ต้องใช้โปรแกรมใด ๆ ชว่ย 

- การสง่ออกไฟล์ ไปท่ีเมน ูFile > Publish… 

1. การสง่ออก เป็น SWF เลือกไอคอน Flash(SWF) 

 

Project Title: ตัง้ช่ือไฟล์ 

Folder: ระบหุ้องท่ีเก็บไฟล์ 
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Output Options: รูปแบบการสง่ออก เลือก ZIP ถ้าจะน าไปใช้กบั LMS ถ้าจะน าไปใช้บน

อินเทอร์เน็ต ให้เลือก HTML ด้วย โดย Captivate จะสร้างไฟล์ HTML ส าหรับใช้เลน่ Flash ให้ 

2. การสง่ออกเป็น EXE ส าหรับเลน่บนเคร่ืองคอมพิวเตอร์ ให้เลือกไอคอน Media 

 
 

Select Type: ระบวุา่จะน าไปใช้เลน่บน Windows หรือ Mac 

Project Title: ระบช่ืุอไฟล์นี ้

Folder : ระบท่ีุอยู่ท่ีจะจดัเก็บ 

Output Options: เลือกรูปแบบ สามารถจดัท าเป็นไฟล์เล่นบนซีดีอตัโนมตั ิพร้อมทัง้ระบรุุ่น

ของ Flash Player 

 

 

 

 

ภาคผนวก 

 

1. ไฟล์ crnfe.php 

 

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

<HTML> 

<HEAD> 

<TITLE> สถาบนั กศน.ภาคกลาง</TITLE> 

<META http-equiv=Content-Type content="text/html; charset=ISO-8859-1"> 

</head> 
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<body> 

<?php 

//โดย อ.ทองจลุ ขนัขาว สถาบนั กศน.ภาคกลาง http://www.crnfe.ac.th 

include ("dbInfo.php"); 

 

foreach ($_POST as $k => $v)  

   { 

      if($k == "Filedata") 

      { 

       if(get_magic_quotes_gpc()) 

  $Filedata = stripslashes($v); 

  else 

  $Filedata = $v; 

      } 

   } 

 

$Filedata = str_replace("\n", "", $Filedata); 

$Filedata = str_replace("\"", "", $Filedata); 

$Filedata = str_replace("</", "", $Filedata); 

$Filedata = str_replace("<", "", $Filedata); 

$Filedata = str_replace("/>", "+++", $Filedata); 

$Filedata = str_replace(">", "+++", $Filedata); 

// $Filedata = str_replace(" ", "",  $Filedata);  

 

$cp5Dat = array();  

$cp5Dat = explode('+++', $Filedata);  

 

$pos = strpos($cp5Dat[4],"="); 

$stName = substr($cp5Dat[4], $pos+1);  

 

$pos = strpos($cp5Dat[3],"="); 

$courseName = substr($cp5Dat[3], $pos+1);  

 

$pos = strpos($cp5Dat[16],"="); 

$RawScore = substr($cp5Dat[16], $pos+1);  

 

$pos = strpos($cp5Dat[23],"="); 

$dateValue = substr($cp5Dat[23], $pos+1);  

 

$pos = strpos($cp5Dat[24],"="); 

$timeValue = substr($cp5Dat[24], $pos+1);  

 

$pos = strpos($cp5Dat[19],"="); 

$sessionTimeValue = substr($cp5Dat[19], $pos+1);  
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//เขียนข้อมลูลงฐานข้อมลู 

$dblink = mysql_connect($host, $usr, $pwd);  

mysql_select_db($db, $dblink);  

$sql = " INSERT INTO score"; 

$sql .= " (stName, courseName, score, dateTaken, beginTime, totalTime) VALUES "; 

$sql .= " ('$stName', '$courseName', '$RawScore', '$dateValue', '$timeValue', '$sessionTimeValue' )"; 

$result = mysql_query($sql, $dblink); 

mysql_close($dblink); 

 

?> 

</body> 

</html> 

 

2. ไฟล์ showscore.php 

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//TH"> 

<html> 

<head> 

<title>สถาบนั กศน.ภาคกลาง</title> 

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"> 

</head> 

<body> 

<?php 

 

  include("dbInfo.php"); 

  $cid = mysql_connect($host, $usr, $pwd); 

  mysql_select_db($db);  

  $sql = "SELECT * FROM score ORDER BY id desc LIMIT 0,15"; 

 

  $result = mysql_query($sql) or die("Couldn't execute query"); 

echo "<table width=\"100%\"><tr><td>ตารางแสดงคะแนนผู้ เข้าทดสอบ 15 คนลา่สดุ</td><td 

aligh=\"right\">&nbsp;</td></tr></table>"; 

 echo "<table border=1 width=\"100%\">"; 

 echo "<TR><TD>ท่ี</TD><TD align=\"center\">ช่ือ</TD><TD align=\"center\">วิชา</TD><TD 

align=\"center\">คะแนน</TD><TD align=\"center\">วนัท่ีสอบ</TD><TD align=\"center\">เร่ิมสอบ

เวลา</TD><TD align=\"center\">ใช้เวลาสอบ</TD></TR>"; 

 

$idx = 0; 

 while ($row= mysql_fetch_array($result)) { 
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  $idx += 1;  

  $stName = $row["stName"]; 

  $courseName = $row["courseName"]; 

  $score= $row["score"]; 

  $dateTaken= $row["dateTaken"]; 

  $beginTime= $row["beginTime"]; 

  $timeTotal= $row["totalTime"]; 

 

  echo "<tr valign = \"top\"><td>$idx</td><td>$stName</td> 

<td>$courseName</td><td>$score</td><td>$dateTaken</td><td>$beginTime</td><td>$timeTotal

</td></tr>"; 

 } 

 echo "</table>"; 

?> 

 

</body> 

</html> 

 

3. ไฟล์ dbInfo.php ส าหรับก าหนดคา่ของ Server เรียกใช้งานโดยไฟล์ crnfe.php และ ไฟล์ 

showscore.php ถ้าลง Xampp โดยไมก่ าหนดรหสัผา่น จะมีดงันี ้

 

<?php 

$usr = "root"; //login name 

$pwd = ""; // รหสัผา่น 

$db = "scorecp5"; // ช่ือฐานข้อมลู 

$host = "localhost"; // host ปกตเิป็น localhost 

?> 

 

4. Shortcut keys 

 
Shortcut key Action 

F1 Open Adobe Captivate Help (To access dialog-box-level help, click the Help button on 

individual dialog boxes.) 

F3 Test view the current slide (Edit view only) 

F4 Preview the project 

F5 Record audio 

F6 Import audio 

F7 Perform a spelling and grammar check 



40 

 

Shortcut key Action 

F8 Preview project from current slide 

F9 Show the Advanced Interaction dialog box 

F10 Preview the current slide and the following “N” slides 

F11 View Adobe Captivate in full screen 

F12 Preview the project in a web browser 

Alt+Up, Down, 

Left, Right 

Arrows 

Click the object, click a resize handle, and use these options to resize the object in the 

selected direction 

Control+A Select all 

Control+B Find audio in the Library 

Control+C Copy (slide in Storyboard view or Filmstrip, and selected object in Edit view) 

Control+D Duplicate (slide in Storyboard view or Filmstrip, and selected object in Edit view) 

Control+E Extend the length of the object display time to the end of the slide on the Timeline (Edit view 

only) 

Control+F Open the Find And Replace dialog box 

Control+F Find/replace a particular object in the project Library 

Control+G Change the slide to optimized quality 

Control+H Change the slide to high quality 

Control+I Increase the indent (selected object in Edit view) 

Control+J Change the slide to JPEG quality 

Control+K Lock the slide 

Control+L Sync the selected object to the playhead 

Control+M Merge the selected object with the background 

Control+N Move to the Slide Notes pane 

Control+O Open the project 

Control+P Align the selected object with the playhead on the Timeline (Edit view only) 

Control+Q Insert a random question slide 

Control+R Print the project (through the Publish dialog box) 

Control+S Save 

Control+T Change the slide to standard quality 

Control+U Edit with (in project Library) 
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Shortcut key Action 

Control+V Paste what is on the clipboard (for example, slide, image, object, and so on) 

Control+W Close the project 

Control+X Cut (selected object in Edit view) 

Control+Y Redo 

Control+Z Undo 

Control + = Zoom in 

Control + - Zoom out 

Control + Up Shift the object upward in the grid 

Control+Tab Shift between Storyboard, Edit, and Branching views 

Control+Alt+A Export PowerPoint slides as animation 

Control+Alt+B Show thumbnails (Edit view only) 

Control+Alt+C Show the Closed Captioning dialog box 

Control+Alt+D Update the Library 

Control+Alt+E Edit the slide group and edit points of polygon drawing object 

Control+Alt+F Find in the Library 

Control+Alt+G Create a slide group and autoadjust the rollover area 

Control+Alt+H Hide the selected object 

Control+Alt+I Find PowerPoint slides in the Library 

Control+Alt+L Show the Library (Edit view only) 

Control+Alt+M Show/hide the Image Edit pane 

Control+Alt+N Show slide notes (Edit view only) 

Control+Alt+O Record additional slides 

Control+Alt+P Remove a slide group. 

Control+Alt+Q Show the Question Pools Manager dialog box 

Control+Alt+R Reset to the original size 

Control+Alt+S Edit PowerPoint slide 

Control+Alt+T Show the Timeline (Edit view only) 

Control+Alt+U Library usage 

Control+Alt+V Show/hide the Design Templates panel 
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Shortcut key Action 

Control+Alt+W Redraw the shape of the rollover slidelet 

Control+Alt+X Show/hide the SWF-Commenting pane 

Control+Alt+Z Show/hide the Widget panel 

Shift+F8 Preferences dialog box 

Shift+F9 Actions dialog box 

Shift+F10 Table of contents 

Shift+F11 Skin Editor dialog box 

Shift+F12 Publish the file 

Shift+Up Shift the object upwards by 10 pixels 

Shift+Control+A Add an animation object (Edit and Storyboard views only) 

Shift+Control+B Add a new button (Edit and Storyboard views only) 

Shift+Control+C Add a new text caption (Edit and Storyboard views only) 

Shift+Control+D View slide properties 

Shift+Control+E Insert a new zoom area (Edit and Storyboard views only) 

Shift+Control+F Insert an FLV file (Edit and Storyboard views only) 

Shift+Control+G Show the Go To Slide dialog box 

Shift+Control+H Hide/show slide 

Shift+Control+I Decrease the indent (selected object in Edit view) 

Shift+Control+J Insert a blank slide (Edit and Storyboard views only) 

Shift+Control+K Add a new click box (Edit and Storyboard views only) 

Shift+Control+L Insert a highlight box 

Shift+Control+M Add a new image 

Shift+Control+N Add a new animation slide 

Shift+Control+O Add a new rollover image 

Shift+Control+P Import PPT 

Shift+Control+Q Insert a question slide 

Shift+Control+R Insert a rollover caption 

Shift+Control+S Insert an image slide 

Shift+Control+T Insert a text entry box 
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Shortcut key Action 

Shift+Control+U Insert the mouse 

Shift+Control+V Paste as background 

Shift+Control+W Insert a widget 

Shift+Control+X Insert a text animation 

Shift+Control+Y Copy the background 

Shift+Control+Z Insert a rollover slidelet 

Magnification shortcuts 

Shortcut key Magnification level 

Control+1 100% 

Control+2 200% 

Control+3 300% 

Control+4 400% 

Control+= Zoom in 

Control+- Zoom out 

Shortcut keys for recording 

The following table lists the default shortcut keys used during recording. These shortcuts should be used only after you start the recording process. 

The same keys function differently when you are editing a project. 

Shortcut key Action 

End Stop recording 

Pause Pause or resume recording 

F8 Resume rerecording 

Print Screen Capture a screenshot manually 

F9 Start full motion recording 

F10 Stop full motion recording 

F4 Automatic panning 

F3 Manual panning 

F7 Stop panning 

F11 Snap the recording window to the mouse 

F12 Toggle mouse capture in full motion recording 
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Change shortcut keys for recording 

1. Select Edit > Preferences. 

2. In the Preferences dialog box, select Keys from the Recording menu. 

3. To change keys, click once in one of the text boxes and, on the keyboard, press the key or key combination you want to use. For 

example, click inside the Stop Recording text box and then press Shift+Alt+4. The key combination you entered now appears in 

the Stop Recording text box. You can use almost any key, including the Control, Alt, Shift+Control, and Shift+Alt keys. For 

example, you could change the stop recording key to Alt+R. 

Change shortcut key for an object 

Use the Shortcut Key dialog box to select a new shortcut key combination. The dialog box appears when you click the Select Keys button available 

for some of the objects in their Properties dialog box. Using the check boxes, key list, and pop-up menus in this dialog box, you can set almost any 

key combination that is possible on a standard computer keyboard as a shortcut key. Examples include Control+Shift+K, Control+Right Arrow, or 

Backspace+M. 

Allow Mouse Clicks  

Select this option to allow users to click in the control.  

Attach A Shortcut  

Select this option to add a shortcut to the selected key.  

Include Numeric Keypad (0–9) Keys  

Select this option to include the numeric keypad keys as part of the shortcut key combination.  

CTRL  

Select this option to include the Control key as part of the shortcut key combination.  

SHIFT  

Select this option to include the Shift key as part of the shortcut key combination.  

ALT  

Select this option to include the Alt key as part of the shortcut key combination.  

Key List  

Select any key from the list to include as part of the shortcut key combination. Use the scroll bar on the right to view the entire list of 

keys.  

Letter Or Number  

Click the pop-up menu to select any letter or number as part of the shortcut key combination.  

Note: The Control, Shift, and Alt keys map to the relevant Macintosh® keys. 

Current Shortcut  

This item lists the current shortcut key combination assigned to the task. As you make selections in the dialog box, this item 

automatically updates so you can view the complete combination you have created.  

Note: If your Adobe Captivate movie will be displayed in a browser, set shortcut keys that do not conflict with common browser 

shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. 

 

 

ปรับปรุงข้อมลูเม่ือ  25 กมุภาพนัธ์ 2555 


